Informática y Sistemas (β)

2009/10/15 - 15 octubre 2009

Recomendaciones para la actualización KB967723 en Windows Server 2008

Filed under: Notas sobre Productos — Mario Mendez @ 16:26
Tags:

Windows UpdateRecientemente Windows Update detectó un batería de actualizaciones, en mi caso hace poco más de un día; que intentó instalar en diversos equipos que utilizo. Sin embargo, una de estas actualizaciones, específicamente la KB967723 (boletín de seguridad MS09-048) tuvo problemas siendo imposible implementarla a través de la utilidad de actualización incorporada.

En efecto, el proceso aborta con el código de error 80070490; cuya referencia en el sitio genérico de Windows tiene una descripción bastante extrema y una secuencia de reparación sumamente costosa y que de ningún modo se justifica frente al fallo de un solo paquete de actualización entre una lista de entre 10 y 15 parches, según la configuración de cada sistema. Por otra parte, de tres sistemas operativos Windows Server 2008 que mantengo, la actualización falló en una versión Web, y una Enterprise configurada como controlador de dominio, pero se instaló sin problemas en otro equipo con la misma versión Enterprise, alojando un servidor de base de datos SQL 2008; por lo que deduzco que el paquete debe ser sensible a la configuración del sistema operativo. Debo aclarar que estos servidores no alojan otros softwares adicionales, siendo muy básicos tanto en su configuración como en su uso; así que esta frecuencia de fallos creo que es de alta incidencia.

Incongruencia aparente entre versiones de la actualización KB967723

Incongruencia aparente entre versiones de la actualización KB967723

La alternativa que me resultó para corregir ambos casos fue el descargar el instalador del parche para ejecutarlo en forma independiente, desde la sección correspondiente a la actualización para Windows Server 2008. Algo que me llamó la atención en el historial de actualizaciones una vez finalizada, es que la descripción de la instalación responde a la leyenda Windows, mientras que la instalación abortada respondía a la descripción de Windows Server 2008. De hecho, el paquete de actualización para Windows Vista tiene el mismo descriptor e idéntico tamaño y propiedades; por lo que me atrevería a pensar de que en realidad se trata del mismo ejecutable.

Como este caso es de excepción, ya que hasta ahora nunca tuve problemas con las actualizaciones automáticas; decidí subir este post esperando ayudar a otros que se enfrenten a este problema.

(tiny)

Anuncios

23 comentarios »

  1. Gracias. Tenía el mismo problema. Con tu post pude resolverlo!

    Comentario por Surf-Reggae — 2009/11/05 - 5 noviembre 2009 @ 18:22 | Responder

  2. Muchas gracias

    Comentario por juan carlos — 2009/11/12 - 12 noviembre 2009 @ 16:37 | Responder

  3. Excelente recomendación, pude solucionar el problema en 3 servidores, me salvaste la vida. Muchas Gracias!!!

    Comentario por Fátima — 2009/11/13 - 13 noviembre 2009 @ 19:41 | Responder

    • De nada! Ahora eso de salvar la vida ¿no será mucho? 🙂

      Comentario por Mario Mendez — 2009/11/13 - 13 noviembre 2009 @ 21:25 | Responder

  4. Muchísimas gracias por la aportación.
    La verdad es que no estaba dispuesto a estas alturas a realizar el procedimiento que dictaba Microsoft, que más que una solución me parecía una premonición de lo que me podía ocurrir después. El problema se ha solucionado.

    Un abrazo

    Comentario por juanjo — 2009/11/15 - 15 noviembre 2009 @ 14:35 | Responder

    • es cierto, esta vez los procedimientos recomendados son desmedidos en relación al problema; y hasta es probable que despues de reinstalar todo vuelva a ocurrir lo mismo. Saludos!

      Comentario por Mario Mendez — 2009/11/15 - 15 noviembre 2009 @ 17:07 | Responder

  5. Pues a mi no me funciono. E intententado con todo. Modo seguro, desactivando el Firewall
    pero no me funciona. Siempre me marca ese error aun cuando lo instale por separado como
    tu lo recomendaste. Al final de intentar instalarlo solo decia “No se instalaron las siguientes actualisasiones” y era la ke abia intentado instalar. Es molesto, tengo meses intentando. Alguna sugerencia?

    Comentario por Obdc — 2010/06/17 - 17 junio 2010 @ 21:07 | Responder

    • lamentablemente no tengo sugerencias alternativas. De hecho un par de meses después de haber tenido este problema tuve uno similar con otra actualización, y pude resolverla del mismo modo.

      Comentario por Mario Mendez — 2010/07/04 - 4 julio 2010 @ 03:54 | Responder

  6. Gracias por tu ayuda, llevaba tiempo con ese error en todos los servidores 2008 x64 y con el método indicado se ha solucionado. Ya estaba cansado de ver el error todos los días. Las soluciones que facilitaban en Microsoft no me daban confianza.

    El link que facilitas es para los Windows 32 bits, el de Windows Server 2008 x64 es http://www.microsoft.com/downloads/details.aspx?displaylang=es&FamilyID=6e46822e-f79d-492d-ad01-ee680ad324f5

    Saludos

    Comentario por Angel — 2010/07/14 - 14 julio 2010 @ 18:29 | Responder

    • Me alegra que te haya resultado positiva la recomendación, y te agradezco por el enlace para los casos de 64 bit, pasa mucha gente por este post buscando solución a este problema y seguramente les servirá ese dato.

      Comentario por Mario Mendez — 2010/07/14 - 14 julio 2010 @ 18:49 | Responder

  7. Será que algun virus no detectado evita que se pueda bajar la actualizacion.
    si tienes algun antivirus para el server 2008 que me puedas recomendar.
    Tengo el symantec endpoint 11.0 y no activa la proteccion proactiva, la da por buena con el check a la izquierda y a la derecha indica desactivada.
    Gracias por tu valiosa colaboracion.

    Comentario por Victor Manuel Aguilar Mora — 2010/08/20 - 20 agosto 2010 @ 06:55 | Responder

    • No creo que el problema del paquete sea por un virus, igualmente si tuviera que recomendar un antivirus sería el mismo que mencionas. Gracias por pasar.

      Comentario por Mario Mendez — 2010/08/21 - 21 agosto 2010 @ 01:31 | Responder

  8. Gracias.

    Tenia el mismo problema y gracias a ti lo he resuelto.
    Por cierto, el problema lo he tenido en un Windows Server 2008 sp2 en español que uso como Workstation.
    Con una configuracion adecuada para ello (entonces no habia salido Windows 7 todavia
    y por otra parte funciona de PM)
    En otros 2008 server que uso como servidores de verdad no he tenido el problema.
    Lo digo por si sirve de pista para alguien. Yo no tengo tiempo ahora para investigar más.

    Pero muchas gracias y tomo nota del remedio para sucesivas ocasiones en que me ocurra algo parecido.

    Un saludo.

    Luis Tark

    Comentario por Luis Tark — 2010/09/20 - 20 septiembre 2010 @ 01:17 | Responder

  9. Este post aún sigue ayudando a resolver este problema!, Gracias por la información

    Comentario por Oscar — 2012/01/12 - 12 enero 2012 @ 02:22 | Responder

    • excelente! gracias por tu feedback y qué bueno que sigue siendo de ayuda este post

      Comentario por Mario Mendez — 2012/01/12 - 12 enero 2012 @ 03:08 | Responder

  10. Hola mi estimado,excente aportacion solo que habia pensado que revolveria mi problema dicha actualizacion ,mi problema es que no me dejaba instalar un sae ,ya quite todo mi seguridad e incluso mi antivirus ,pero no completa las instalaciones,cres que se deba al instaler,tengo win server 2008 ? ,saludos ..

    Comentario por Romus — 2012/07/03 - 3 julio 2012 @ 03:12 | Responder

  11. Gracias, tu recomendación me ayudo mucho.

    Comentario por Raul — 2014/03/24 - 24 marzo 2014 @ 17:57 | Responder

  12. Gracias el problema se soluciono buena aportación

    Comentario por Altesa — 2014/07/03 - 3 julio 2014 @ 18:35 | Responder

  13. Yo tenia el mismo problema, Es fantastico que hayas compartido tu experiencia.

    Comentario por alcubierre7 — 2014/07/31 - 31 julio 2014 @ 11:55 | Responder

  14. Muchisimas gracias, tenia ese problema por unos meses!!!!

    Comentario por Piramide Kefren — 2014/10/31 - 31 octubre 2014 @ 21:22 | Responder


RSS feed for comments on this post. TrackBack URI

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Crea un blog o un sitio web gratuitos con WordPress.com.

A %d blogueros les gusta esto: